Dynamic Labs - Delays sending OTP for emails – Incident details

All systems operational

Delays sending OTP for emails

Resolved
Operational
Started 21 days agoLasted 36 minutes

Affected

API

Operational from 4:24 PM to 5:00 PM

3rd Party Services

Operational from 4:24 PM to 5:00 PM

Updates
  • Resolved
    Resolved

    We experienced deliverability issues between SendGrid and the ISPs

    We implemented a fix and are currently monitoring the result.

    We are implementing additional improvements in the next couple of days

  • Investigating
    Investigating
    We are currently investigating this incident.